Wednesday, January 9, 2008

Sharepoint Search not working. Event ID 2424

Search not working, Application Log filled with Event ID 2424

Event Type: Error Event Source: Windows SharePoint Services 3 Search
Event Category: Gatherer
Event ID: 2424
User: N/A
Computer: ComputerName
Description: The update cannot be started because the content sources cannot be accessed. Fix the errors and try the update again. Context: Application 'Search', Catalog 'index file on the search server Search'

Resolution
Central Administration -> Operations -> Services on server -> Click on the Windows Sharepoint Services Search service and make sure that the 'Service Account' and 'Content Access Account' service account specified are the same. They should not be working with two separate accounts. If it still does not work, Stop the service and while starting it again specify a common service account and create a new Search Database.

5 comments:

Anonymous said...

Hi
my Sharepoint server search is not working.i followed your points.and i stopped the service in under Operation in Services on Server tab in "Windows SharePoint Services Search" afterthat i can't start again the service.It's showing below the error.

WSS_Search_ESPROD on ESPROD\OfficeServers contains user-defined schema. Databases must be empty before they can be used. Delete all of the tables, stored procedures and other objects or use a different database.

Troubleshoot issues with Windows SharePoint Services.

How to solve the problem.please help me.
Thanks in advance,Vel

Parmi said...

hi,

Please delete the database or rename the database "WSS_Search_ESPROD". sharepoint is trying to create a new search database and find the file already exists so its not able to overwrite the schema of that database.

hope this helps.

Anonymous said...

Hi Parmi,

Thanks for your response

I renamed my database (WSS_Search_ESPROD to WSS_Search_ESPROD070709) and added under (Central Administration > Operations > Services on Server > Windows SharePoint Services Search) page in Search database area, after that I started service "Windows SharePoint Services Search”. The service is started.

But the Search is not working; I am getting below the Event ids: 6482, 7076, and 6398

Please help me

Thanks in advance,Velmurugan

Anonymous said...

For what it's worth... Those three errors pop up in my logs from time to time... the only fix I've found is restarting the Windows Sharepoint Services Timer. It's only temporary; they usually come back in a week or two, but I searched long and hard, and it was the only thing that worked, (and at least it's simple to do again).

Anonymous said...

The three errors 6398, 6482, 7076 are fixed with hotfix from MS KB946517.