Tuesday, May 20, 2008

Error while creating a new page in MOSS.

Getting the below error while creating a new page in Moss 2007 while using publishing or collaboration portal template.



List does not exist The page you selected contains a list that does not exist.

It may have been deleted by another user.



In ULS Logs the error listed is as below.

05/16/2008 13:13:34.51 w3wp.exe (0x1AF8) 0x148C Windows SharePoint Services General 8kh7 High List does not exist The page you selected contains a list that does not exist. It may have been deleted by another user. 05/16/2008 13:13:34.51 w3wp.exe (0x1AF8) 0x148C Windows SharePoint Services General 8nca Verbose Application error when access /_layouts/AccessDenied.aspx, Error=List does not exist The page you selected contains a list that does not exist. It may have been deleted by another user. at Microsoft.SharePoint.Library.SPRequestInternalClass.GetListsWithCallback(String bstrUrl, Guid foreignWebId, String bstrListInternalName, Int32 dwBaseType, Int32 dwBaseTypeAlt, Int32 dwServerTemplate, UInt32 dwGetListFlags, UInt32 dwListFilterFlags, Boolean bPrefetchMetaData, Boolean bSecurityTrimmed, Boolean bGetSecurityData, ISP2DSafeArrayWriter p2DWriter, Int32& plRecycleBinCount) at Microsoft.SharePoint.Library.SPRequest.GetListsWithCallback(String bstrUrl, Guid foreignWebId, String bstrListInternalName, Int32 dwBaseType, Int32 dwBaseTypeAlt, Int32 dwServerTemplate, UInt32 dwGetListFlags, UInt... 05/16/2008 13:13:34.51* w3wp.exe (0x1AF8) 0x148C Windows SharePoint Services General 8nca Verbose ...32 dwListFilterFlags, Boolean bPrefetchMetaData, Boolean bSecurityTrimmed, Boolean bGetSecurityData, ISP2DSafeArrayWriter p2DWriter, Int32& plRecycleBinCount) 05/16/2008 13:13:34.51 w3wp.exe (0x1AF8) 0x148C Windows SharePoint Services General 0 Verbose Releasing SPRequest with allocation Id {BD5F0900-38A4-40AB-BC1F-E78319A3DD70}



Resolution
=========
Go to Site Settings -> Master page Gallery -> Add Authenticated Users group and give Read Restricted Access rights.


Add the same group in Style Library and give the same permissions.

6 comments:

Anonymous said...

Thanks !!
I had the same problem, it worked fine.

William Piersol said...

Thanks! That fixed my problems to. But I still would like to know why. It had worked in the past, and then one day it does not.

Do these groups have access by default and somehow where removed?

Shae said...

This worked for me but now subsites have the same problem unless I break inheritance not of the SUBSITE, but of its master page gallery. And repeat the process for hundreds of subsites. Is there a better way?

Parmi said...

Hi Shae,

I am not sure why it broke your subsites. do they have unique permissions? or are they inheriting permissions from parent site. Check the master page gallery permissions of the subsite and make sure they are not using Unique permissions.

Parmi

Eric said...

Worked like a charm.

Thank you VERY much!!

Srikanth's SharePoint Blog said...

How to add ? some one give example for this